Quick tip for people who have dist-upgraded their Debian-flavour distro and suddenly found that wpa-supplicant doesn’t work: you can now remove ndiswrapper, because native drivers are here at last:

sudo rmmod ndiswrapper

Don’t forget to remove ndiswrapper from the list of modules that load at startup as well.